Сколько у Вас рабочих мест 1С?

Рейтинг@Mail.ru

Процедура ОтправитьEmail(Получатель,Тема="",ТекстПисьма="",ФайлыВложений=Неопределено) Экспорт

Письмо = Новый ИнтернетПочтовоеСообщение;
Письмо.ИмяОтправителя = СокрЛП("1С");
Получатель = Письмо.Получатели.Добавить();
Получатель.Адрес = Получатель;
Письмо.Тема = Тема;
Письмо.Тексты.Добавить(ТекстПисьма);

Если ФайлыВложений<>Неопределено Тогда
Для Каждого ФЛ из ФайлыВложений Цикл
Письмо.Вложения.Добавить(ФЛ);
КонецЦикла;
КонецЕсли;

ПрофильОтправки = Новый ИнтернетПочтовыйПрофиль;
ПрофильОтправки.АдресСервераSMTP = Константы.SMTPсервер.Получить();
ПрофильОтправки.АутентификацияSMTP = СпособSMTPАутентификации.ПоУмолчанию;
ПрофильОтправки.ПользовательSMTP = Константы.SMTPПользователь.Получить();
ПрофильОтправки.ПарольSMTP = Константы.SMTPПароль.Получить();

Почта = Новый ИнтернетПочта;
Попытка
Почта.Подключиться(ПрофильОтправки);
Исключение
Сообщить("Электронное сообщение не отправлено: "+ОписаниеОшибки());
Возврат;
КонецПопытки;

Попытка
Почта.Послать(Письмо);
Исключение
Сообщить("Электронное сообщение не отправлено: "+ОписаниеОшибки());
Возврат;
КонецПопытки;

Почта.Отключиться();

КонецПроцедуры